Infraestrutura Ágil

Soluções e métodos inteligentes para sua infra

Puppet 3.6.x allow_virtual warning

| Comments

Se você atualizou seu Puppet para a versão 3.6.x, possivelmente deve ter recebido o warning abaixo quando executa o puppet agent.

1
2
Warning: The package type's allow_virtual parameter will be changing its default value from false to true in a future release. If you do not want to allow virtual packages, please explicitly set allow_virtual to false.
   (at /usr/lib/ruby/site_ruby/1.8/puppet/type.rb:816:in `set_default')

Esse warning informa que o parâmetro allow_virtual passará a ser true nas releases futuras do puppet. Caso deseje desativar esse recurso, você deverá fazê-lo de forma explícita no arquivo site.pp.

1
2
3
4
5
6
if versioncmp($::puppetversion,'3.6.1') >= 0 {

  Package {
    allow_virtual => false,
  }
}

[s]
Guto

Comments